Новые iOS-приложения должны будут поддерживать IPv6

Новые iOS-приложения должны будут поддерживать IPv6

В блоге для разработчиков Apple появилось сообщение о том, что с 1 июня 2016 года все новые приложения в App Store должны будут иметь поддержку IPv6. Изначально переход на шестую версию Интернет-протокола компания анонсировала в прошлом году на конференции WWDC 2015, предупредив, что подобное требование вскоре появится. Некоторому количеству приложений, которые уже добавлены в App Store, будет необходимо обновить код, чтобы поддерживать IPv6-сети.

Новые iOS-приложения должны будут поддерживать IPv6

На сайте библиотеки для разработчиков Apple уже появилась инструкция, которая поможет разработчикам приложений совершить необходимые обновления. Большую часть разработчиков нововведение не затронет, так как основная масса приложений использует системный API для работы в сети. Очевидно, что со своей стороны Apple сделает всё необходимое, чтобы системный фреймворк поддерживал их собственные требования.

Протокол IPv6 - новый стандарт работы сетей, призванный сменить столкнувшийся с проблемой нехватки адресов IPv4. Ожидается, что со временем IPv6 полностью заменит предшественника. Таким образом, введение новых требований со стороны Apple показывает стремление компании заранее подготовить свои платформы к изменениям технологической экосистемы.

Источник: 4pda.ru

Оставить комментарий

Смотреть популярные каналы